Jak nainstalovat a nastavit skener v zařízeních Hewlett-Packard (ovladač HPLIP)

skener-bubbleUrčitě znáte multifunkční zařízení HP, která umí tisknout, kopírovat a skenovat. Třeba jedno takové máte a vcelku spokojeně používáte. Ale používáte ho i pro skenování, nebo jen tisknete? Vím, že zařízení HP mají přímou podporu výrobce, který také pro Linux vyvíjí ovladač. Ale až nedávno jsem byl vystaven požadavku rozchodit skenování. A tady jsem na kvality HPLIP narazil v praxi. Čekal jsem trochu víc. Takže návod zbyl na mně, tady ho máte. 🙂

Vím, že o tom psal Lukáš Zapletal, ale jednak jsem to nehledal (viz dále) a jednak je jeho návod už starší a „moje“ situace měla háček.

Co nefungovalo a o čem vlastně píšu

V Ubuntu 10.10 je nainstalovaný (nebo je možné nainstalovat) ovladač HPLIP pro zařízení Hewlett-Packard. Na obrázku – omlouvám se za chybějící okraje, už by tu „vlastnost“ sakra mohli opravit – vidíte, že zařízení bylo nalezeno. Jeho ovládací nabídka obsahuje několik voleb. Protože chci skenovat, klepnu na Scan.

Dočkal jsem se hlášky, že došlo k chybě vstupu a výstupu při čtení ze zařízení. Ostatně to ukazuje i obrázek se stavem zařízení. Tam jsem uviděl, že je třeba instalovat onen plugin (chápu to spíš jako firmware).

hplip-ubuntu-status

Klikl jsem tedy na Install required plugin, zobrazilo se okno, v němž jsem vybral první položku – download plugin from web nebo tak nějak. Skvělé, tak to má být, myslel jsem si asi sekundu, než se objevilo okno s chybovým hlášením, že plugin nelze stáhnout. Huh. Okno jsem zrušil a zkusil jsem tedy kliknout na položku znovu. Kupodivu to nepomohlo. Vše skončilo stejnou chybou.

Shrnuto: Skener potřebuje firmware, klikací průvodce, který ho má nainstalovat, nefunguje. Ve správci softwaru jsem nic v tomto duchu nenašel a ani třetí pokud se nezdařil. Tak co dál?

Jak najít a nainstalovat plugin

Nebudu psát o tom, jak jsem hledal – chvilku mi to trvalo. Napíšu už jen výsledky. V první řadě bystě měli zjistit, jakou verzi balíku HPLIP používáte. Bude to napsané v hlavní nabídce Help a také ve správci softwaru.

Stáhněte si plugin, a to včetně souboru s příponou asc, ve kterém je uložen otisk potvrzující pravost souboru. Vyberte si verzi, která odpovídá vaší verzi HPLIP – jinou nepůjde nainstalovat. Soubory si uložte na disk. (Může mi někdo vysvětlit, proč jsou ty moduly tak zasekané a nevede na ně velké červené tlačítko z webu hplipopensource.com?)

Pokud budete nyní postupovat výše uvedeným způsobem, tedy kliknutím na tlačítko Install required plugin a pokud vyberete druhou možnost, tedy instalaci z lokálního souboru, možná překvapivě neuspějete.

Až z terminálu jsem vyčetl chybu

Downloading plug-in from: file:///home/plastique/temp/hplip-3.10.2-plugin.run
Traceback (most recent call last):
File "/usr/share/hplip/ui4/plugindialog.py", line 279, in NextButton_clicked
self.plugin_download_callback)
File "/usr/share/hplip/installer/core_install.py", line 1942, in download_plugin
log.error("Plug-in GPG file download failed: %s" % e.strerror)
File "/usr/share/hplip/base/logger.py", line 320, in error
txt = "error: %s" % message.encode("utf-8")
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 39: ordinal not in range(128)

To tedy jednoho depotěší. Jediným řešením, které jsem našel, je:

  1. Chopte se svých kořenových práv (su případně sudo před následující příkaz).
  2. V adresáři, kde jsou uloženy stažené soubory, spusťte hp-plugin -i -p souborpluginu, tedy např. hp-plugin -i -p hplip-3.10.2-plugin.run
# hp-plugin -i -p hplip-3.10.2-plugin.run 

HP Linux Imaging and Printing System (ver. 3.10.2)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press  to accept the default.)

/
-----------------------------------------
| PLUG-IN INSTALLATION FOR HPLIP 3.10.2 |
-----------------------------------------

---------------
| COPY PLUGIN |
---------------

Downloading plug-in from: file:///home/plastique/temp/hplip-3.10.2-plugin.run
Downloading plug-in: [**************************************************************************************] 100%  8.0 KB   Receiving digital keys: /usr/bin/gpg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0xA59047B9

----------------------
| INSTALLING PLUG-IN |
----------------------

Verifying archive integrity... All good.
Uncompressing HPLIP 3.10.2 Plugin Self Extracting Archive...................................

HP Linux Imaging and Printing System (ver. 3.10.2)
Plugin Installer ver. 3.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.10.2
Installed HPLIP version: 3.10.2
Number of files to install: 30

You must agree to the license terms before installing the plug-in:

LICENSE TERMS FOR HP Linux Imaging and Printing (HPLIP) Driver Plug-in                                                             

[následuje nudná licence]

Do you accept the license terms for the plug-in (y=yes*, n=no, q=quit) ? y

Done.

Done.

A to je všechno. Zatím nevím, kam nahlásit nalezenou chybu – nefunkční dialog pro instalaci modulu. Poradíte?

Pro skenování doporučuji Simple scan nebo gscan2pdf. XSane, které je předvolené, je složitý a odpudivý bazmek. Ne že by toho neuměl hodně, ale k čemu to, když potřebujete skenovat jednu áčtyřku?

Podobné čtení

Jak v Ubuntu instalovat úlohy, tedy více balíků na... Úloha je tzv. metabalíček - tedy pomyslný souhrn všech konkrétních balíčků,...jejichž instalací se získá kompletní řešení pro nějakou činnost. Chcete-li...např. kompletní webový server (tj. Apache, MySQL, PHP neboli /L/AMP), pak stačí...instalovat úlohu LAMP.
openMagazin skončil a jsem rád Když jsem oznamoval mailem partnerům, že ukončujeme openMagazin, prosil jsem je, ať o...tom nikde nepíšou hned, ale počkají, že to chci nejprve oznámit v newsletteru. Ale...stalo se samozřejmě mnohem něco horšího - nejenže na mail vůbec nikdo neregoval,...ale dodneška to svým čtenářům neoznámili (pokud se dobře dívám).

7 komentářů u “Jak nainstalovat a nastavit skener v zařízeních Hewlett-Packard (ovladač HPLIP)

  1. Firemní HP Color Laserjet 2840, připojený po síti, byl stejný oříšek, nerozchodil jsem jen fax, než jsem se k němu dostal, přešli jsme na SIP a tam už fax nechtěl fungovat. Naopak se s tímto HPčkem dostávám do stejné situace, jako se scannerem doma – zařízení není úplně nové a pro Win novější než XP není ovladač, takže pod GNU/Linuxem běhá a nové počítače s Win7 mohou jet jen na generickém ovladači černobíle, bez scanneru. Docela mě tím HP naprdlo, ty velké tiskačky se nekupují na rok, ale ve firmě jedou třeba 5—8 let.

  2. UnicodeDecodeError: ordinal not in range(128) to je prostě pythonovský evergreen. Tohle je už potřetí za poslední dobu, co vidím že programátor „zaskočen“ výpisem na utf-8 terminál. Pán nám vypisuje stringy i unicode stringy hlava nehlava do připraveného loggeru. Naprosto stejný problém jsem v lednu opravoval u jiného projektu:

    https://git.fedorahosted.org/git/?p=pulp.git;a=commitdiff;h=192540cb3c56b1dce9c4ca8f54a981bef52f0fda

    Hlavně na západ to utf-8 kódovaní stále ještě ne a ne strávit. A to už je sakra doba, kdy Red Hat Linux přepnul na utf-8 (a po něm všechny ostatní distribuce). Hádám že díky Pythonu 3.0 nás to ještě chvíli bude provázet.

  3. >Zatím nevím, kam nahlásit nalezenou chybu – nefunkční dialog pro instalaci modulu. Poradíte?

    https://bugs.launchpad.net/hplip

    Musí jít o nějakou dočasnou chybu. Něco podobného jsem na té samé tiskárně kdysi řešil, pro změnu chyběl balík hplip-gui. Po jeho instalaci bylo vše OK.

  4. zdravim,

    diky za tip. Resim tu jeste scanovani pres sit i lokalne s timto zarizenim: HP_LaserJet_M1120n_MFP. Tak to mozna pomuze.

    gf

  5. V září 2011 byly kompromitovány servery Linux Foundation, kam patří také OpenPrinting. Pluginy proto nejde stáhnout a je dost problematické je najít. Na této stránce by mohl být vždy ten aktuální (stránku jsem vždy našel jen Googlem, korporátní weby HP jsou příšerné):

    https://hplipopensource.com/hplip-web/plugin_download.html

    Anebo hledejte Googlem, vždy přímo název souboru, např. hplip-3.11.7-plugin.run. Našel jsem ho třeba tady:

    ftp://ftp.upm.edu.ph/softwares/linux_drivers/HP%20Printers/

    Samozřejmě bez záruky, nevím nic o zdroji, odkud to mají.

  6. I po mnoha letech, vzdy po reinstalaci Linuxu, vzdy tento clanek navstivim a znovu zopakuji. Diky!

Komentáře nejsou povoleny.

Pin It on Pinterest